Analytics temporarily down
Incident Report for Appen
Resolved
The issue has been identified and resolved. Analytics are now available. Please reach out to help@appen.com if you are still having issue accessing this feature.
Posted Nov 16, 2022 - 10:52 PST
Investigating
Analytics feature is temporarily unavailable. We are working to restore this feature. Please contact help@appen.com if your work is being blocked
Posted Nov 16, 2022 - 08:29 PST