Platform Degradation

Incident Report for Appen External

Resolved

This incident has been resolved.
Posted Oct 25, 2024 - 12:07 PDT

Update

We are ongoing with the implementation of fixes for the issue, and our team is actively working towards a resolution. We will provide further updates as we make progress.
Posted Oct 24, 2024 - 20:30 PDT

Update

We are ongoing with the implementation of fixes for the issue, and our team is actively working towards a resolution. We will provide further updates as we make progress.
Posted Oct 24, 2024 - 13:21 PDT

Update

We are continuing to implement fixes for this issue. We will provide further updates as we make progress.
Posted Oct 24, 2024 - 10:06 PDT

Identified

We have identified the cause of the degraded platform performance and errors and are currently working on implementing fixes. We appreciate your patience and understanding as we address this issue. We will keep you updated with any significant developments.
Posted Oct 24, 2024 - 07:06 PDT

Update

We are continuing our investigation into the platform degradation issue. Our team is actively working to resolve it as quickly as possible.
Posted Oct 23, 2024 - 14:34 PDT

Investigating

We are currently experiencing platform-wide degradation and errors. The team is actively investigating the issue to resolve it.
Posted Oct 23, 2024 - 13:59 PDT
This incident affected: Customer Portal and API.