Failure to log in to Appen Connect

Incident Report for Appen External

Resolved

This incident has been resolved.
Posted Dec 20, 2022 - 15:08 PST

Update

We are continuing to work on a fix for this issue.
Posted Dec 20, 2022 - 15:08 PST

Identified

We have found and identified an issue blocking authentication to Appen Connect via connect.appen.com and are implementing a fix now.
Posted Dec 20, 2022 - 15:07 PST
This incident affected: Customer Portal and API.