Platform Degradation

Incident Report for Appen External

Resolved

This incident has been resolved.
Posted Nov 06, 2024 - 18:39 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2024 - 18:32 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 06, 2024 - 18:12 PST

Investigating

We are currently experiencing platform-wide degradation and errors. The team is actively investigating the issue to resolve it.
Posted Nov 06, 2024 - 16:46 PST