Platform incident

Incident Report for Appen External

Resolved

This incident has been resolved.
Posted Jun 28, 2022 - 01:27 PDT

Update

The issue has been identified and resolved.
Posted Jun 28, 2022 - 01:27 PDT

Investigating

We are experiencing a platform incident and are investigating.
Posted Jun 28, 2022 - 01:20 PDT
This incident affected: Customer Portal and API.