Appen Connect failure to login
Incident Report for Appen
Resolved
We have addressed issues around users with failing logins and functionality is now restored for all users.
Posted Dec 20, 2022 - 19:04 PST
Update
We have started the process to fix the issue observed on the remaining users.
Posted Dec 20, 2022 - 18:40 PST
Monitoring
We are implementing a fix now for internal users first before applying for all users.
Posted Dec 20, 2022 - 16:38 PST
Investigating
We are currently investigating an issue affecting Appen Connect.
Posted Dec 20, 2022 - 15:41 PST
This incident affected: Customer Portal and API.